System Requirements for Akana Platform 2018.0.0

The following table lists the minimum system requirements for running Akana Platform 2018.0.0

For instructions for installing or upgrading, see Installing the Akana API Platform 2018.0.0 or Upgrading Akana API Platform from Version 8.4x to Version 2018.0.x.

Supported Platforms: 2018.0.0

Name Requirement
Akana Platform Host

Hardware:

Single CPU, 2Ghz, 2GB RAM (minimum)

Operating Systems:

  • Windows—Windows Server 2012
  • Linux—CentOS Linux 7.x or equivalent
Client browser for accessing developer portal

Default Theme and Hermosa Theme:

  • Firefox version 25 and later
  • Chrome version 31 and later
  • Internet Explorer versions 11 and later

DevOps Theme:

  • Firefox version 25 and later
  • Chrome version 31 and later
  • Internet Explorer versions 11 and later

Simple Developer Theme:

  • Firefox version 32 and later
  • Chrome version 38 and later
  • Internet Explorer versions 11 and later
Database versions

Akana API Platform 2018.0.0 supports the following database versions:

  • MySQL 5.6 and 5.7

    Database driver required: see Database drivers (install doc).

    Note: If you're using MySQL 5.6 with version 8.0.x or later of Policy Manager, the Akana Platform, or Community Manager, you must configure some specific MySQL property settings. See MySQL Database Property Settings.

  • Oracle 12c, 12c Release 2

    Database driver required: see Database drivers (install doc).

  • Microsoft SQL Server 2012
  • MongoDB (Windows 64-bit MSI and Linux 64-bit TGZ): version 3.2.18 and later, 3.4.x, 3.6.x

    To download a MongoDB Version 3.2.18 file for your platform, refer to the MongoDB Downloads website.

Note: Depending on the database type and version that you're using, there might be specific requirements, constraints, or additional steps needed. For details, refer to the Database Notes section of the installation documentation.

Memory configuration

The default maximum heap size for all Akana Containers (Java processes) is 2048 MB.

Recommended: 4096 MB

Elasticsearch

Supported versions: 6.3.1.

See Installing and Configuring Elasticsearch.

Back to top