System Requirements for Akana Platform 2020.1.x

The following table provides information about the minimum system requirements for running Akana Platform/Akana API Platform 2020.1.x, and about associated supported technologies, such as API description document formats.

For instructions for installing or upgrading, see Installing the Akana API Platform 2020.1.x or Upgrading Akana API Platform to Version 2020.1.x.

Supported Platforms: 2020.1.x

Platform Requirements

Third-Party Technologies/Solutions Supported


Platform Requirements

Name Requirement
Akana Platform Host

Hardware per Akana container:

2Ghz CPU, dual core, 4GB RAM minimum, 6GB recommended.

Note: The above assumes a dedicated CPU for each container.

Operating Systems:

  • Windows Server
    • 2012 R2

      Note: Microsoft support of Windows Server 2012 R2 ends in October 2023.

    • 2016
  • Linux
    • CentOS Linux 7.x
    • Ubuntu 16.x, 18.x
    • Red Hat Enterprise Linux Server 7.4

    Note: In general, any Linux version that supports the Akana Platform JRE compatible versions (see JRE version below) should be operable.

Memory configuration:

Default maximum heap size for all Akana Containers (Java processes): 2048 MB.

Recommended: 4096 MB

JRE version:

  • The Akana Platform is compatible with JRE 1.8 and is shipped with OpenJDK JRE version 1.8.0_275. You can also configure the platform to use an external JRE. For more information, see Configuring an External JRE.
Client browser for accessing Community Manager developer portal

All themes:

  • Firefox version 72.0 and later
  • Chrome version 70 and later
  • Internet Explorer versions 11.1282 and later
  • Microsoft Edge version 44.18362 and later.
Database versions

Akana API Platform 2020.1.x supports the following database versions:

  • MySQL 8.0

    Database driver required: see Database drivers (install doc).

  • Oracle 12c Release 2, Oracle 18c (18.3), Oracle 19c.

    Note: The Oracle database password must not start with a number or special character.

    Database driver required: see Database drivers (install doc).

  • Microsoft SQL Server:
    • 2012 SP4

      Note: Microsoft support of SQL Server 2012 SP4 ends in July 2022.

    • 2016 SP2
  • MongoDB (Windows 64-bit MSI and Linux 64-bit TGZ):
    • 4.2.11 and later 4.2.x versions supported in version 2020.1.5 and later.
    • 4.0.19 and later 4.0.x versions supported in version 2020.1.5 and later.

      Note: MongoDB support of version 4.0.x ends in April 2022.

    • 3.6.versions up to 3.6.16.

      Note: MongoDB support of version 3.6.x ended in April 2021.

    To download a MongoDB file for your platform, refer to the MongoDB Downloads website.

Note: Depending on the database type and version that you're using, there might be specific requirements, constraints, or additional steps needed. For details, refer to the Database Notes section of the installation documentation.

Elasticsearch

(Required for Community Manager only)

Supported versions:

  • 6.8.6 and later 6.x.x versions

Recommended for the standalone Elasticsearch server: 4GB RAM, 25GB disk space

Depending on the usage and the number of objects, more disk space might be needed.

See Installing and Configuring Elasticsearch.

Note: In version 2020.2.0, Elasticsearch version 7.8 will be required. Earlier versions of Elasticsearch will not be supported on 2020.2.0.

Third-Party Technologies/Solutions Supported

Name Details
API description document formats

The platform supports adding an API by uploading, or otherwise referencing, API description documents in any of the following formats:

For more information, see API Description Language Support (Community Manager developer portal documentation).

Third-party identity and access management (IAM) technologies

OAuth Support:

Any providers that are compliant with the applicable OAuth specification are supported. For example, PingFederate versions 9.3.x and 10.0.x are supported out of the box.

OpenID Connect Support:

Any providers that are compliant with the specification are supported.

SAML Identity System:

SAML Web SSO

Any providers that are compliant with the specification are supported.

SiteMinder

  • R12.0 SP3

Kerberos

  • Supported on Windows Server versions 2012 R2, 2016

Kafka version

Valid in version: 2020.1.1 and later

Kafka version supported: Version 2.2.1.

Back to top