System Requirements for Akana Platform 8.2x

The following table lists the minimum system requirements for running Akana Platform 8.2x.

For instructions for installing or upgrading, see Installing the Akana API Platform 8.2x or Akana API Platform: Upgrade Guide Version 8.0 to 8.2 (PDF).

Supported Platforms: 8.2x

Name Requirement
Akana Platform Host

Hardware:

Single CPU, 2Ghz, 2GB RAM

Operating Systems:

  • Windows - Windows Server 2008, Windows Server 2012, Windows 10
  • Linux - Red Hat Enterprise Linux 5.8, 6.2, 7
Client browser for accessing developer portal

Default Theme and Hermosa Theme:

  • Firefox version 25 and later
  • Chrome version 31 and later
  • Internet Explorer version 9 and later

Simple Developer Theme:

  • Firefox version 32 and later
  • Chrome version 38 and later
  • Internet Explorer version 9 and later
Database versions

Akana API Platform 8.2 supports the following database versions:

  • MySQL 5.6
  • Oracle 11g, 12c
  • Microsoft SQL Server 2012 and 2014 (supported in version 8.4.2 and later)

If you are using MySQL 5.6 with version 8.0.x or later of Policy Manager, the Akana Platform, or Community Manager, you must configure some specific MySQL property settings. See MySQL Database Property Settings.

Memory configuration

The default maximum heap size for all Akana Containers (i.e., Java processes) is 2048 MB.

Recommended: 4096 MB.

MongoDB

Supported versions: 3.2.12, 3.2.13, and later versions up to 3.2.18, Windows 64-bit (MSI) and Linux 64-bit (TGZ).

To download a MongoDB Version 3.2.18 file for your platform, refer to the MongoDB Downloads website.

Back to top